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Running rovibrational calculations in PGOPHER 
 Marissa Weichman, Princeton University  June 2023 
 
  
All you need to run PGOPHER on a Windows machine is the executable file sourced from here. 
 
PGOPHER can do a lot of things, and there is a lot of detailed documentation available from the 
dedicated website here, as well as various online and published resources including: 

  
• The original PGOPHER paper in the Journal of Quantitative Spectroscopy and Radiative Transfer. 

More details than you could possibly want. 
  

• Here's a recent nice paper from folks at PNNL walking through some specific examples of PGOPHER 
simulations for both high- and low-symmetry molecules. 
  

• Paper 1 and Paper 2 on using PGOPHER to fit experimental spectra (MLW has not done much of this, 
so please share your expertise if you end up using it!) 

  
• This useful appendix from Matt Sprague's thesis at Caltech on Gaussian inputs for PGOPHER 

simulation 
  

Here I'll walk through a few basic ways to simulate rovibrational spectra with PGOPHER. 
  

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

https://pgopher.chm.bris.ac.uk/download/
https://pgopher.chm.bris.ac.uk/
https://www.sciencedirect.com/science/article/pii/S0022407316300437
https://pubs.aip.org/aip/adv/article/13/5/055133/2892570
https://pubs.rsc.org/en/content/articlehtml/2017/cp/c7cp00266a
https://pubs.rsc.org/en/content/articlehtml/2018/cp/c8cp06493h
https://thesis.library.caltech.edu/7086/37/Sprague_Matthew_Thesis_App_D.pdf


2 
 

 
 

HITRAN input to PGOPHER 
If your molecule of interest is covered in the HITRAN line-by-line database, you're in great luck. All you 
have to do is download the relevant .par file for your desired molecule and import it in PGOPHER. 

From here, pretty much your only adjustable parameters are  
• T, temperature in Kelvin 
• Gau, Gaussian line broadening (full width at half maximum) in cm-1. Typically use expected 

Doppler linewidth at temperature T 
•  Lor, Lorentzian line broadening (full width at half maximum) in cm-1. Typically use expected 

pressure broadening linewidth. 

https://hitran.org/lbl/
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• More info on simulation parameters here 

 
You can click File > Export > Main Plot to save a file with x,y values from the plot window. 

Gaussian input to PGOPHER 
Say we want to study an unusual molecule not documented in HITRAN. We can create rovibrational 
simulations from scratch using the output from Gaussian calculations. Here we'll walk through 
simulating the rovibrational band of a single fundamental vibrational mode. 
  
First, run a freq calculation in Gaussian with the iop(7/33=1) keyword so dipole derivatives are printed 
for vibrational normal modes.  
  
Here, I'll use the output from a Gaussian harmonic frequency calculation at the B3LYP/6-31g level for 
the D2h pyrene molecule as an example.  
  
This system is going to be an asymmetric top. It's also helpful to have the character table for the 
relevant point group handy. 
  

First, let's collect various pieces of information from our Gaussian output: 
 

1. Molecular structure 
--------------------------------------------------------------------- 
Center     Atomic      Atomic             Coordinates (Angstroms)  
Number     Number       Type             X           Y           Z  
---------------------------------------------------------------------               
 1          6           0        0.000000    0.000000    0.714802 
  2          6           0        0.000000    0.000000   -0.714802 
  3          6           0        0.000000    1.239197    1.432217 
  4          6           0        0.000000    1.239197   -1.432217 
  5          6           0       -0.000000   -1.239197    1.432217 
  6          6           0       -0.000000   -1.239197   -1.432217 
  7          6           0        0.000000    2.469414    0.682704 

https://pgopher.chm.bris.ac.uk/Help/simulation.htm
https://pgopher.chm.bris.ac.uk/Help/asymmetrictops.htm
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  8          6           0        0.000000    2.469414   -0.682704 
  9          6           0       -0.000000   -2.469414    0.682704 
  10          6           0       -0.000000   -2.469414   -0.682704 
  11          6           0        0.000000    1.213769    2.839570 
  12          6           0        0.000000    1.213769   -2.839570 
  13          6           0       -0.000000   -1.213769    2.839570 
  14          6           0       -0.000000   -1.213769   -2.839570 
  15          6           0        0.000000    0.000000    3.531937 
  16          6           0        0.000000    0.000000   -3.531937 
  17          1           0        0.000000    3.405972    1.232946 
  18          1           0        0.000000    3.405972   -1.232946 
  19          1           0       -0.000000   -3.405972    1.232946 
  20          1           0       -0.000000   -3.405972   -1.232946 
  21          1           0        0.000000    2.152534    3.385882 
  22          1           0        0.000000    2.152534   -3.385882 
  23          1           0       -0.000000   -2.152534    3.385882 
  24          1           0       -0.000000   -2.152534   -3.385882 
  25          1           0        0.000000    0.000000    4.617306 
  26          1           0        0.000000    0.000000   -4.617306 
  

In this orientation, the molecule is in the y-z plane, with y along the shorter axis, and z along the longer 
axis of the molecule; see cartoon below. 

  
  

2. Rotational constants for the ground vibrational state of the molecule: 

Rotational constants (GHZ):           1.0055831           0.5524280           
0.3565522 

By convention, rotational constants are A > B > C. So here,  
A = 1.0055831 GHz 
B =  0.5524280 GHz 
C =  0.3565522 GHz 
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We can correlate these rotational constants with rotation about one of the three principle axes of the 
molecule, which in the standard orientation are aligned to the Cartesian axes.  I tend to do this by 
inspection: rotational constants are inversely proportional to the moment of inertia for rotation about 
the relevant principle axis. So the largest rotational constant A corresponds to rotation about the axis 
with the smallest moment of inertia, etc. See cartoon below, which correlates A <> rotation about z, B 
<> rotation about y, C <> rotation about x. For some additional info, see my notes on rotational 
spectroscopy in polyatomic molecules. 

  
It will be useful at this point to determine the asymmetric top axis system that PGOPHER will want to 
use to represent this molecule. 
 
A<>z, B<>y, C<>x corresponds to the "Il" axis system. Hold onto this info! 
 
 
 
 
 
 
 

 
3. Vibrational frequencies  

  
Now look at the vibrational mode you are interested in. In this example, we'll use mode 53 of pyrene, 
the B1u symmetry IR-active mode near 1487 cm-1: 

                            53     
     B1U 
Frequencies ---   1487.0913  
Reduced masses ---      3.0672  
Force constants ---     3.9964  
IR Intensities ---     12.1813  
Raman Activities ---    0.0000  
Depol. (Plane) ---      0.0000  
Depol. (Unpol) ---      0.0000  

https://weichman.princeton.edu/wp-content/uploads/2022/05/3-Rotational-Spectroscopy.pdf
https://pgopher.chm.bris.ac.uk/Help/asymsym.htm
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 Coord Atom Element:     
1     1     6         -0.00000  
2     1     6         -0.00000  
3     1     6         -0.10786   
1     2     6          0.00000  
2     2     6          0.00000  
… etc  

 

4. And finally, let’s dig out the vibrational dipole derivatives for this mode: 

Dipole derivative wrt mode  53: -3.63779D-12 -7.67078D-11 -3.49017D+00 

Polarizability derivatives wrt mode         53 

                 1             2             3 
      1   0.000000D+00  0.000000D+00  0.000000D+00 
         2   0.000000D+00  0.000000D+00  0.000000D+00 
               3   0.000000D+00  0.000000D+00  0.000000D+00 
Vibrational polarizability contributions from mode  53       0.0000000       
0.0000000       0.1482352 

Vibrational hyperpolarizability contributions from mode  53       
0.0000000      -0.0000000      -0.0000000 
 
IFr=  0 A012= 0.48D-21 0.27D-14 0.46D-15 Act= 0.32D-14 DepolP= 0.00D+00 
DepolU= 0.00D+00 

Here, we can see the dipole derivatives along the x,y,z Cartesian axes. Note, the sum of the squares of 
these components should equal the total IR intensity in km/mol! 

  
For this example, we can see the only significant dipole derivative is along the z axis. We can also 
validate this by looking at the vibrational normal mode displacements visualized in GaussView or 
Avogadro. For this high-symmetry molecule, the character table for the point group alone will also tell 
you that B1u vibrations change the dipole of the molecule along the z axis. (This assumes of course that 
the character table uses the same conventions for the Cartesian axes as the standard orientation in 
Gaussian- always a big assumption and good to double check). 

  
In any event, we have convinced ourselves that mode 53 has a net stretching motion aligned along the 
z-axis, and therefore along the A rotational axis. This vibrational motion is therefore an a-type transition. 
Hold onto this info! 

  
Note: a, b, and c-type vibrational transitions will have very different looking rotational patterns 
accompanying them. It's worth playing around with simulating band profiles for B1u, B2u, and B3u 
modes in a D2h molecule, for instance, to explore this. 
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Now let’s get into the PGOPHER simulation. 
  

a. Open PGOPHER, and select File > New > Asymmetric Top 
 

b. Now open up the constants panel through View > Constants. Everything we'll need to do is filling in 
parameters in the Constants panel. There are five items to define in particular: the simulation 
parameters (Simulation), the molecular species (Species), the molecular symmetry (Asymmetric 
Top), the vibrational level properties (v=0 and v=1), and the transition moment integrals (tabs under 
<Excited|mu|Ground>) 

 
  
 
 
 
 
 
 
 
 

c. Under the Simulation tab 
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Here are the parameters to focus on here: 
• Fmin, Fmax: this is the frequency window. You can set it here, but it will also update automatically 

when you change the plot range in the GUI. 
• Temperature (Kelvin) 
• Gaussian and Lorentzian fwhm (leaving 0 is ok to create a stick spectra) 
• IntensityUnits: arbitrary or normalized is fine if you don't need absolute values. Otherwise, (cm^2 

wavenumber/molecule) is the same as spectral line intensity Sij from HITRAN data. More on this 
here and in the 2017 PGOPHER paper. 

• nDF: number of points within spectrum; somewhat important when exporting plotted data. 
d. Under the Species tab, all you need to check is the value of Jmax (maximum rotational quantum 

number plotted), which may have to be increased for big molecules or at high temperatures 

https://hitran.org/docs/definitions-and-units/
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e. Under the Asymmetric Top tab there are several important items 

 
  

  
The parameters to focus on here are: 
• PointGroup. For pyrene we use D2h. 
• Representation: again, this is what determines which inertial axis is which Cartesian axis, as detailed 

here. For the pyrene example we put Il, as detailed above. 

https://pgopher.chm.bris.ac.uk/Help/asymsym.htm
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• eeWt, eoWt, oeWt, ooWt can be used to handle nuclear spin statistics in systems with 
indistinguishable nuclei (like ortho- and para- states in H2O for instance). We'll not get into this with 
this example. 

• C2zAxis and C2xAxis relate the C2 symmetry axes for the molecule's point group with the inertial 
axes. See the section for the specific point group on this page for how best to define these. For our 
D2h system, we again use the relation between the z <> A and x <> C axes. In practice, if you get 
these wrong, the transitions you are looking for often become forbidden, so it's pretty easy to tell 
when these axes are defined incorrectly. 

 
 
f. We now get into the v=0 and v=1 parameters 

 
  

For v=0, we define parameters for the lower vibrational state, from which transitions derive. 
• Origin: Set the origin of the ground state to 0 cm-1 (or whatever reference energy you'd like to use). 
• A,B,C: Enter the rotational constants for the ground vibrational state, from our Gaussian calculations 
• S: set the spin of the lower electronic state 

https://pgopher.chm.bris.ac.uk/Help/asymsym.htm
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• Symmetry: Set the symmetry of the lower state, in this case to Ag, since the vibrational ground state 
of a closed shell molecule is totally symmetric. 

• Note there are many many constants here (DK, DJK, DJ, deltaK, deltaJ…). These are centrifugal 
distortion constants that come from vibration-rotation interaction. They will provide small 
corrections to the spectrum, and we neglect them here. You can in principle find these in an 
anharmonic Gaussian calculation, or sometimes in the precision spectroscopy literature. 
  

For the vibrationally excited state, v=1, the parameters look much the same, but we enter the origin and 
symmetry of the vibrational mode of interest. Here's what we enter for pyrene: 

 
Note: For simplicity I've used the same rotational constants here as I did for the v=0 state. One should 
really update these with vibrational state-specific rotational constants by performing anharmonic 
frequency calculations. For big molecules like pyrene, anharmonic calculations are pretty expensive, so I 
have not taken this step in this example.  
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g. Finally, let's get into the transition dipole moment parameters: 
  

 
  

• Axis: needs to be consistent with the direction of transition dipole and how it aligns with the inertial 
axes. For this B1u vibration of pyrene, we had determined this to be the a axis.  

• Strength: here left as 1, since we are using arbitrary units for the peak intensities 
  

Note: In a low symmetry molecule, a single vibration may well have transition dipole moment 
components along more than one inertial axis, making it some simultaneous combination of a,b, and/or 
c-type transitions. To account for this, simply right-click on <Excited|mu|Ground> then click Add New > 
Cartesian Transition Moment, and provide the relative strengths of the two components using the 
relative weighting of dipole derivatives along each axis from the Gaussian calculations. For pyrene B1u-
symmetry mode 53, recall that these dipole derivatives looked like: 

  

Dipole derivative wrt mode  53: -3.63779D-12 -7.67078D-11 -3.49017D+00 

Since the derivatives along x and y are 11 orders of magnitude smaller than that along z, we can safely 
ignore them in this example. More about this in this paper about C1 symmetry (or lack thereof) 
molecules. 

Finally, below is the produced spectrum for our pyrene rovibrational band, evaluated at 10 K. 

https://pubs.aip.org/aip/adv/article/13/5/055133/2892570
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